Pike's Mozilla Firefox Add-ons

Get Firefox!

Clone Window

Get Clone Window
Version 0.2.9

Clones the current tab's address and history into a new window when the New Window command is used (and optionally into a new tab when the New Tab command is used).

Note: If you're looking for on demand tab duplication then the Duplicate Tab add-on might be more suitable.

Frequently Asked Questions (FAQ)

1. How do I configure Clone Window to clone tabs?

Go to Tools->Add-ons->Extensions->Clone Window->Options, then set the New Tab command to Clone Tab.

Contributors

Release History

0.2.9

  • Added support for Firefox 3 final.

0.2.8

0.2.7

  • Added compatibility with the latest nightlies ( and above).

0.2.6

0.2.5

  • Fixed another compatibility issue with newer Firefox 1.0+ nightly builds.
  • Added a French (fr-FR) locale, contributed by Mori.
  • Added a German (de-DE) locale, contributed by Patrick Ruh.

0.2.4

  • Fixed compatibility issue with Firefox 1.0+ nightly builds.

0.2.3

  • The contents of forms are now cloned into new windows/tabs (this feature still needs more work).
  • Removed the automatic install.rdf update link due to bandwidth constraints, from now on you'll have to manually check for updates.

0.2.2

  • Cloned windows/tabs duplicate the zoom factor of the original page.
  • If installed, the All-in-One add-on's Duplicate Tab gesture is overridden by Clone Window's own version.
  • If installed, the Optimoz Mouse Gestures add-on's Duplicate Tab gesture is overridden by Clone Window's own version.

0.2.1

0.2

  • Added ability to override the New Tab command to clone the current tab into a new tab, or to open the first home page in a new tab (these options are disabled by default).
  • A Ctrl-N keypress can (optionally) be made to open a cloned version of the current tab in a new tab.
  • Cloned windows/tabs remember the scroll position of the original page.

0.1.2

0.1.1

  • If installed, the All-in-One add-on's Duplicate Window gesture is overridden by Clone Window's own version.

0.1

  • Initial Release.

Comments

#241 pomidor

Hi,

Every time I update FF (FireFox), like I did today from v 6 to 7, Firefox tells me that the CW (Clone Window) add-on will not work with the new version of FF, yet CW is supposed to be compatible with that version of FF, and v6 before that, and v5, etc...

So, and as I did with previous FF updates and similar warnings, I go ahead and update FF regardless of the warning. After the update, CW does not work. I.e.: After FF upgrade, CTRL+N opens a new FF session (default and un-cloned).

The solution: remove CW from FF add-ons, and then reinstall CW. After that, CW works fine

This happens every time a new version of FF comes out.

Since removing and installing CW gets the CW to work with FF properly again, one would argue that CW is compatible with that version of FF, yet it kinda' isn't right after a FF upgrade.

FF at fault or CW? If CW is at fault, could you guys tweak it so that the reinstall of CW isn't necessary after an update of a major-release of FF?

thanks

pomidor

#242 FX Trader

I agree with pomidor. This would be great if you didn't have to reinstall it every time.

#243 Pike

@pomidor

You don't need to uninstall the old version, just reinstall CW. This is the fault of my extensions, not Firefox, I hope to resolve this at some point but it might be a lot of work and I don't have the time right now.

#244 pomidor

FF just upgraded itself on one of my other computers, and I tried what you suggested (reinstall CW without uninstalling the old one). It worked like you said. Not perfect, but it does eliminate the uninstall step.

FF should have a "reinstall" button in addition to the existing "disable" and "uninstall" ones. Fixing CW after FF upgrade would then be a just a one-button click.

I wish FF wasn't trying to copy Chrome in the speed at which to do new major releases. Less releases = less times we need to re-install CW.

Speaking of Chrome; are there any future plans to do a CW add-on for Chrome?

#245 Pike

@pomidor

No, I don't have any plans for other browsers.

#246 John

Can you plz update create shortcut so it is compatible with FF 7.0.1. I would appreciate it.

thx

#247 Tom

I tried Clone Window 0.2.9 on Firefox 7.0.1 and when I tried to do a search in Yahoo Mail and open the email that it found, the page would open up blank.
Having problems opening pages.

I am a long time user of clone window. Is there somewhere we can sign up to find out when there is a new version that is compatable?

#248 Pike

@Tom

So is the problem only on Yahoo Mail or all pages? I will try to test again tomorrow but Clone Window worked okay with Firefox 7 beta so I'm not sure why it would break with 7.0.1.

#249 Pike

Could those people having problems with Clone Window and Firefox 7.0.1 please give the exact steps to reproduce the issue, I'm currently unable to find any issues in my own testing. Thanks.

#250 Alatriste España

Hello, I just installed the v8 firefox does not support the Shortcut Creater v0.3.6

#251 Mike

Hi Pike,

Thanks so much for this - I've been using your updates for a long time and having to re-add every new version. I appreciate it. It's strange that Firefox wouldn't give this option - but I imagine everytime their home-page gets clicked on, they register a little point - and maybe the exec gets a chocolate cup-cake on Friday or a 4.8 million dollars if the clicks hit a certain target... Either way, its painful to use the internet without your clone application! Thanks for this!

Mike

#252 Peter

Clone Window works fine for me with all versions of Firefox, up through 9.0.1. Thanks for providing it. I dislike the need to reinstall with every Firefox version. I blame Firefox for it, in spite of what you say. I mean, it is compatible, so their message is wrong.

#253 TC

I was forced to update to newest Firefox, and it says clone is incompatible with new version. Are you planning an update?

#254 David

Hooray! Clone Window 0.2.9 is still compatible with Firefox 13. The trick of extracting the install.rdf file from the XPI file, updating it with a much larger maxVersion value, and re-zipping it works perfectly. For details, see http://kb.mozillazine.org/Editing_an_add-on_to_change_its_compatibility . I set my em:maxVersion to 25.0.* - that should hold me for a few months of releases. :-)

#255 Pike

@David

Firefox 10 and later ignore maxVersion (except in certain situations) so hopefully you shouldn't need to edit the install.rdf file any more.

#256 Q

The ignoring of maxVersion does not seem to apply for global extensions (tested in using the "extensions" directory of the Firefox 10 Program directory). So editing the install.rdf for compatibility is still necessary.

The newer extension compatibility behavior seems to only apply to extension in local profiles.

#257 Q

Actually, it seems like Firefox 10 does use the maxVersion information from install.rdf files for extensions in local profiles.

It seems that install.rdf maxVersion is compared against the value stored in the Firefox extensions.minCompatibleAppVersion preference variable instead of the actual Firefox version.

#258 gvyfcglkef

asmaonohmnuxgavjumlmkzfsrpdwnffxwvifxobybdheqdytdhtpzjamejdlfobrwfpffohgprakodjfarhmdfghja

#259 Denise Thibault

Mathieu mentored through Revis; upon Jets' radar? Tuesday January Twenty two, The year 2013 Three:56 Pm hours Through Kimberley A. Martin Picture credit: GettyTyrann Mathieu鈥檚 visit associated with contrition has begun.The former LSU cornerback is actually making the actual models at this year鈥檚 Older Bowl, indicating their need to get his football life back on track. He was a rising celebrity within Baton Rouge, winning the actual Chuck Bednarik Honor (provided to the best opponent in college football) during a This year period that ended with a 21-0 beatdown from Alabama within the National...

#260 airmaxs39159

Howdy, i read your blog occasionally and i own a similar one and i was just wondering if you get a lot of spam comments? If so how do you prevent it, any plugin or anything you can recommend? I get so much lately it's driving me crazy so any assistance is very much appreciated.

Post Comment

Add your comment in the box below (you may use Quake-style colour codes in your name).

Back to the index page